Examen De Fin De Module : Techniques de programmation structurées

janvier 7, 2014 dans 1ére année par admin

EFM

Examen De Fin De Module

AU TITRE DE L’ANNEE : 2012/2013
VARIANTE 1

Filière : TRI               Niveau : TS           N° du module : 12       Intitulé du module :Techniques de programmation structurées

Exercice 1(10pt):

Une entreprise désire automatisée la gestion de paie de son personnel pour chaque employé, on doit introduire le nom, le prénom, le salaire debase, le nombre d’enfant et l’ancienneté.
A. Un prix de 100dhs est accordé pour chaque enfant.
B. Si ancienneté<= 10 ans et SB<1000 dhs on accorde une prime de 50% du SB
C. Si l’ancienneté est : 10 ans<ANC<20 ans et SB>1000 dhs Prime de 70% du SB
Calculer le salaire brute (SB+la prime+les enfants) et afficher le nom, le prénom, l’ancienneté, SB, prime et le salaire brute pour chaque employé.

Exercice 2(6pt):

Exécuter les algorithmes partiels suivants et déterminer les valeurs qui seront affichées à l’écran.
1.(2 points)
a←20
b←30
Si a > b
Alors a←b
Fin Si
Ecrire (a, b)
2. (2 points)
a←10
b←5
c←4
b←a
a←b
Si a > b
Alors c←b
Sinon a←c
Fin Si
Ecrire (a, b, c)3. (2 points)
a←3
b←2
c←3
Si a > b et b > c
Alors a←100
Fin Si
Ecrire (a)

Exercice 3(14pt):

1 Exécuter l’algorithme partiel suivant: (4 points)
Pouri =1 jusqu’à15 Faire
Si mod 2=0 alors
Ecrire(” Pair “)
Sinon
Ecrire(” Impair “)
Fin Si
Fin pour
2 Réécrire l’algorithme précédent en utilisant tant que.(5pts)
3 Réécrire l’algorithme précédent en utilisant répéter. .(5pts)

Exercice 4(10pts):

Ecrire un algorithme qui permet de saisir une liste de 10 nombres entiers dans un tableau, puis affiche le nombre le plus grand (maximum) avec sa position dans le tableau